Borne mvs2 problème image

Vous voulez parler de système d'arcade, de borne d'arcade, de joystick, de hardware console. Vous voulez des infos sur un point technique, c'est ici.
Message
Auteur
Avatar de l’utilisateur
Enskynet
stick de bronze
Messages : 207
Inscription : 26 déc. 2020, 18:30
A remercié : 3 fois
A été remercié : 0

Re: Borne mvs2 problème image

#26 Message par Enskynet »

MErci Rom1 pour l'info.

Pour ton problème c'est normal que le Neo geo diag ne donne rien. Si tu n'as pas d'affichage un minimum correct et que cela vient "avant" de pouvoir afficher des infos, tu peux mettre ce que tu veux comme bios tu n'auras rien.

Avatar de l’utilisateur
Rom1
stick d'argent
Contact :
Messages : 555
Inscription : 26 avr. 2016, 00:07
Localisation : Aperture Science Enrichment Center
A remercié : 3 fois
A été remercié : 20 fois

Re: Borne mvs2 problème image

#27 Message par Rom1 »

Image

Plus sérieusement, le diagbios n'est pas magique et ne sauve pas tout. Il faut couper le watchdog, regarder sur quoi se plante le 68k et voilà.
Ventes SEGA Ringedge1&2, Slots, jeux et converts MVS, Adaptateurs MVS/JAMMA/Jeutel/System16, Capkit MTC9000, Bios Naomi, etc.
Achats & Réparations NeoGeo MVS, Namco ES3, Sega RingEdge, Sega ST-V, etc. Contactez moi en MP.
DSB Clone - SEGA Digital Sound Board replacement.

Avatar de l’utilisateur
Rom1
stick d'argent
Contact :
Messages : 555
Inscription : 26 avr. 2016, 00:07
Localisation : Aperture Science Enrichment Center
A remercié : 3 fois
A été remercié : 20 fois

Re: Borne mvs2 problème image

#28 Message par Rom1 »

Enskynet a écrit : 21 avr. 2021, 20:50 MErci Rom1 pour l'info.

Pour ton problème c'est normal que le Neo geo diag ne donne rien. Si tu n'as pas d'affichage un minimum correct et que cela vient "avant" de pouvoir afficher des infos, tu peux mettre ce que tu veux comme bios tu n'auras rien.
Faux.

Le diagbios peut démarrer alors qu'un bios normal ne boot pas. C'est parce-que le diagbios est plus petit, n'utilise pas toutes les adresses et toute la ram. Ceci est d'ailleurs indiqué dans le readme.
Ventes SEGA Ringedge1&2, Slots, jeux et converts MVS, Adaptateurs MVS/JAMMA/Jeutel/System16, Capkit MTC9000, Bios Naomi, etc.
Achats & Réparations NeoGeo MVS, Namco ES3, Sega RingEdge, Sega ST-V, etc. Contactez moi en MP.
DSB Clone - SEGA Digital Sound Board replacement.

chipgame32
stick de plomb
Messages : 56
Inscription : 05 mars 2021, 22:04
A remercié : 0
A été remercié : 0

Re: Borne mvs2 problème image

#29 Message par chipgame32 »

j'ai ponté le watchdog mais comment voir sur quoi le 68k se plante?

Avatar de l’utilisateur
Rom1
stick d'argent
Contact :
Messages : 555
Inscription : 26 avr. 2016, 00:07
Localisation : Aperture Science Enrichment Center
A remercié : 3 fois
A été remercié : 20 fois

Re: Borne mvs2 problème image

#30 Message par Rom1 »

Tu peux regarder l'état du bus d'adresse et le r/w. Cela va t'indiquer ce que faisais le 68k.

La table d'adressage est disponible sur le wiki neogeodev.

As-tu vérifié ne serait-ce que l'oe du bios et de la workram ?
Ventes SEGA Ringedge1&2, Slots, jeux et converts MVS, Adaptateurs MVS/JAMMA/Jeutel/System16, Capkit MTC9000, Bios Naomi, etc.
Achats & Réparations NeoGeo MVS, Namco ES3, Sega RingEdge, Sega ST-V, etc. Contactez moi en MP.
DSB Clone - SEGA Digital Sound Board replacement.

chipgame32
stick de plomb
Messages : 56
Inscription : 05 mars 2021, 22:04
A remercié : 0
A été remercié : 0

Re: Borne mvs2 problème image

#31 Message par chipgame32 »

non malheureusement je ne suis pas aussi calé que toi à ce niveau

Avatar de l’utilisateur
Rom1
stick d'argent
Contact :
Messages : 555
Inscription : 26 avr. 2016, 00:07
Localisation : Aperture Science Enrichment Center
A remercié : 3 fois
A été remercié : 20 fois

Re: Borne mvs2 problème image

#32 Message par Rom1 »

Si un cpu de crash il faut de suite vérifier s'il accède bien au programme (le bios ici) et à la ram. Regarde le pinout de chaque composant pour voir où sont les signaux CE/OE/WE pour voir s'il y a de l'activité.

Ça devrait t'aider à trouver l'origine.
Ventes SEGA Ringedge1&2, Slots, jeux et converts MVS, Adaptateurs MVS/JAMMA/Jeutel/System16, Capkit MTC9000, Bios Naomi, etc.
Achats & Réparations NeoGeo MVS, Namco ES3, Sega RingEdge, Sega ST-V, etc. Contactez moi en MP.
DSB Clone - SEGA Digital Sound Board replacement.

chipgame32
stick de plomb
Messages : 56
Inscription : 05 mars 2021, 22:04
A remercié : 0
A été remercié : 0

Re: Borne mvs2 problème image

#33 Message par chipgame32 »

ok je vais essayer ce weekend je te fais un retour. j'ai tous les composants pour me faire un supergun ça sera plus pratique que de la remettre à chaque fois dans la borne déjà pour tester.
Merci pour ton aide

Avatar de l’utilisateur
Enskynet
stick de bronze
Messages : 207
Inscription : 26 déc. 2020, 18:30
A remercié : 3 fois
A été remercié : 0

Re: Borne mvs2 problème image

#34 Message par Enskynet »

Ha ok !
Je pensais que le bios n'était pas accessible tant qu'il n'y avait pas de signal vidéo en output.

Dans mon cas, mon slot MV4 retourne ceci avec J2 ponté et peut importe quel bios:

https://www.youtube.com/watch?v=0pFt1FpgXAw

Avatar de l’utilisateur
Rom1
stick d'argent
Contact :
Messages : 555
Inscription : 26 avr. 2016, 00:07
Localisation : Aperture Science Enrichment Center
A remercié : 3 fois
A été remercié : 20 fois

Re: Borne mvs2 problème image

#35 Message par Rom1 »

C'est super joli.
Tu peux mettre le doigt sur le lspc sans te brûler ?
Ventes SEGA Ringedge1&2, Slots, jeux et converts MVS, Adaptateurs MVS/JAMMA/Jeutel/System16, Capkit MTC9000, Bios Naomi, etc.
Achats & Réparations NeoGeo MVS, Namco ES3, Sega RingEdge, Sega ST-V, etc. Contactez moi en MP.
DSB Clone - SEGA Digital Sound Board replacement.

Avatar de l’utilisateur
Enskynet
stick de bronze
Messages : 207
Inscription : 26 déc. 2020, 18:30
A remercié : 3 fois
A été remercié : 0

Re: Borne mvs2 problème image

#36 Message par Enskynet »

Rom1 a écrit : 21 avr. 2021, 21:56 C'est super joli.
Tu peux mettre le doigt sur le lspc sans te brûler ?
Oui. Il est à peine tiède et encore. Même température que le Yamaha je dirais au feeling. Faut que je mette le dos de mon doigt pour ressentir qu'il est tiède.

chipgame32
stick de plomb
Messages : 56
Inscription : 05 mars 2021, 22:04
A remercié : 0
A été remercié : 0

Re: Borne mvs2 problème image

#37 Message par chipgame32 »

rom1 tu peux être plus précis stp au niveau des pinout des composants je n'ai pas compris

Avatar de l’utilisateur
Rom1
stick d'argent
Contact :
Messages : 555
Inscription : 26 avr. 2016, 00:07
Localisation : Aperture Science Enrichment Center
A remercié : 3 fois
A été remercié : 20 fois

Re: Borne mvs2 problème image

#38 Message par Rom1 »

Tu dois regarder la datasheet des composants pour avoir leur pinout. De la tu regardes s'il y a de l'activité sur les signaux importants comme CE/OE/WE, les horloges, etc...
Autre vérification: quand le 68k se bloque (signal HALT low) tu peux regarder la valeur du bus d'adresse pour savoir à quoi il accédait et en déduire quel composant fait défaut.
Ventes SEGA Ringedge1&2, Slots, jeux et converts MVS, Adaptateurs MVS/JAMMA/Jeutel/System16, Capkit MTC9000, Bios Naomi, etc.
Achats & Réparations NeoGeo MVS, Namco ES3, Sega RingEdge, Sega ST-V, etc. Contactez moi en MP.
DSB Clone - SEGA Digital Sound Board replacement.

pnauts
stick d'or
Messages : 1391
Inscription : 25 nov. 2016, 10:31
Localisation : Pas loin de Nîmes.
A remercié : 0
A été remercié : 0

Re: Borne mvs2 problème image

#39 Message par pnauts »

Il faudrait que tu regardes en priorité le bus d'adresse et de données du 68K au scope (et globalement sur chaque composant sur lequel il est pour vérifier qu'une piste n'est pas coupée)
globalement pour un MV2F il faut regarder les composants suivants:
68K
sys ROM (pulses sur pin 20)
les 2 backup RAM (pin 22 et 27)
les 2 work RAM (pin 22 et 27)
le HC259 et le HC32
NEO-B1 (pulses 3,8Hz en pin 88,89 et 91)
NEO-C1 (pin 12 & 96 plus facile d'y accéder sur le NEO-G0 situé en B7 sur les pins 60 & 61)
NEO-IO (pulses en pin 29,30 en "ou" des 2 sort en 31)
toutes les horloges soient présentes en sortie du NEO-D0 (tu as déjà celle de base sinon ton 68K ne tournerait pas)
http://www.necstasy.net/

Image

Pony MK III

Avatar de l’utilisateur
chacal
stick d'or
Messages : 1452
Inscription : 05 sept. 2005, 21:35
Localisation : Thionville
A remercié : 0
A été remercié : 0

Re: Borne mvs2 problème image

#40 Message par chacal »

Salut :-D

on dirais que la piste est coupé ici :?

je vois encore des taches de Girafe j'appel ça comme cela :lol: des taches d'oxydation encore sur tes pistes tache vert foncé 8O j'ai encadré en rouge.

Image

Si tu a un Stylo en fibre de verre mettre a nu les pistes c'est mieux 8)

Aprés tu applique ça quand tout fonctionnera avec une lamp UV :wink:

Image

https://fr.aliexpress.com/item/40001118 ... 4f71R3SxsL
Tous ce qui sont touch?s par la main de Toki
ressentent le paradis avant de mourir euguéééé?

chipgame32
stick de plomb
Messages : 56
Inscription : 05 mars 2021, 22:04
A remercié : 0
A été remercié : 0

Re: Borne mvs2 problème image

#41 Message par chipgame32 »

chacal a écrit : 24 avr. 2021, 10:46 Salut :-D

on dirais que la piste est coupé ici :?

je vois encore des taches de Girafe j'appel ça comme cela :lol: des taches d'oxydation encore sur tes pistes tache vert foncé 8O j'ai encadré en rouge.

Image

Si tu a un Stylo en fibre de verre mettre a nu les pistes c'est mieux 8)

Aprés tu applique ça quand tout fonctionnera avec une lamp UV :wink:

Image

https://fr.aliexpress.com/item/40001118 ... 4f71R3SxsL
Pourtant j'ai fais les tests de continuité et tout est bon. mais je vais faire ce que tu dis ça peut que être mieu. Ou je peux trouver lle schéma de cette carte avec la nomenclature des composants? Je vais changer tous les petits composants autour de la pile ils ont une sale gueule

pnauts
stick d'or
Messages : 1391
Inscription : 25 nov. 2016, 10:31
Localisation : Pas loin de Nîmes.
A remercié : 0
A été remercié : 0

Re: Borne mvs2 problème image

#42 Message par pnauts »

tu peux oublier la partie ZMC2 et NEO257 de ton problème à priori, c'est la partie côté cartouches. J'ai déjà vu plein de pistes comme ça ce n'est surement pas coupé mais l'absence de vernis probablement.
Le schéma du slot 1 est sur le wiki mais fondamentalement c'est la même chose.

https://wiki.neogeodev.org/index.php?title=Schematics

La plupart des composants sont des customs chips spécial SNK tu auras du mal à les trouver, il faut commencer à regarder les signaux indiqués au scope plus haut, commence par les WRAM et backup RAM et le NEO-IO

https://wiki.neogeodev.org/index.php?ti ... gory:Chips
http://www.necstasy.net/

Image

Pony MK III

chipgame32
stick de plomb
Messages : 56
Inscription : 05 mars 2021, 22:04
A remercié : 0
A été remercié : 0

Re: Borne mvs2 problème image

#43 Message par chipgame32 »

pnauts a écrit : 24 avr. 2021, 15:35 tu peux oublier la partie ZMC2 et NEO257 de ton problème à priori, c'est la partie côté cartouches. J'ai déjà vu plein de pistes comme ça ce n'est surement pas coupé mais l'absence de vernis probablement.
Le schéma du slot 1 est sur le wiki mais fondamentalement c'est la même chose.

https://wiki.neogeodev.org/index.php?title=Schematics

La plupart des composants sont des customs chips spécial SNK tu auras du mal à les trouver, il faut commencer à regarder les signaux indiqués au scope plus haut, commence par les WRAM et backup RAM et le NEO-IO

https://wiki.neogeodev.org/index.php?ti ... gory:Chips
merci pour les schéma je n'avais pas réussi à les trouver. Mais c'est compliqué de lire ce qu'il y a marqué et surtout de comprendre c'est pas aussi simple que les cartes de flipper. par exemple sur le IO, je dois regarder le signal de quelle patte et quesque je dois en deduire surtout pour savoir si il est bon ou pas et comment le composant qui reçois le signal doit réagir.

pnauts
stick d'or
Messages : 1391
Inscription : 25 nov. 2016, 10:31
Localisation : Pas loin de Nîmes.
A remercié : 0
A été remercié : 0

Re: Borne mvs2 problème image

#44 Message par pnauts »

Relire ce qu-il y a marqué plus haut.
http://www.necstasy.net/

Image

Pony MK III

chipgame32
stick de plomb
Messages : 56
Inscription : 05 mars 2021, 22:04
A remercié : 0
A été remercié : 0

Re: Borne mvs2 problème image

#45 Message par chipgame32 »

j'ai commencé mes test donc d'abord sur le neo IO
pin 29
neo IO pin29.jpg
pin30
neo IO pin30.jpg
Dis moi si mes mesures te conviennent
Vous ne pouvez pas consulter les pièces jointes insérées à ce message.

chipgame32
stick de plomb
Messages : 56
Inscription : 05 mars 2021, 22:04
A remercié : 0
A été remercié : 0

Re: Borne mvs2 problème image

#46 Message par chipgame32 »

pour le NEO B1
pin88 sonde x10
neo B1 pin88.jpg
pin 89 sonde x10
neo B1 pin 89.jpg
pin 91
neo B1 pin 91.jpg
Vous ne pouvez pas consulter les pièces jointes insérées à ce message.

pnauts
stick d'or
Messages : 1391
Inscription : 25 nov. 2016, 10:31
Localisation : Pas loin de Nîmes.
A remercié : 0
A été remercié : 0

Re: Borne mvs2 problème image

#47 Message par pnauts »

88, 89 tu trigges pas correctement, faut faire du single et 10ns de base de temps c'est trop peu, 91 ok.
NEO-IO 20mV/div non ! faut oublier l'utilisation en autoset de l'oscillo, travaille en 1V/div ou 2V/div
il faut regarder la pin 59 du G0 situé en b7 aussi
et les 22,27 des Wram.
http://www.necstasy.net/

Image

Pony MK III

chipgame32
stick de plomb
Messages : 56
Inscription : 05 mars 2021, 22:04
A remercié : 0
A été remercié : 0

Re: Borne mvs2 problème image

#48 Message par chipgame32 »

oui je vais le faire mais vu que l'oscillo c'est la deuxième fois que je m'en sers je voulais voir si c'était bon. Je test dans 15mn ce que tu me dis

chipgame32
stick de plomb
Messages : 56
Inscription : 05 mars 2021, 22:04
A remercié : 0
A été remercié : 0

Re: Borne mvs2 problème image

#49 Message par chipgame32 »

pnauts a écrit : 26 avr. 2021, 20:23 88, 89 tu trigges pas correctement, faut faire du single et 10ns de base de temps c'est trop peu, 91 ok.
NEO-IO 20mV/div non ! faut oublier l'utilisation en autoset de l'oscillo, travaille en 1V/div ou 2V/div
il faut regarder la pin 59 du G0 situé en b7 aussi
et les 22,27 des Wram.
Je mets la sonde en x10?

chipgame32
stick de plomb
Messages : 56
Inscription : 05 mars 2021, 22:04
A remercié : 0
A été remercié : 0

Re: Borne mvs2 problème image

#50 Message par chipgame32 »

j'ai refais un test avec la pin 89 en single en 200ns ça donne ça
20210426_205726.jpg
Vous ne pouvez pas consulter les pièces jointes insérées à ce message.

Répondre